With reduced image width % comes empty space | and | setting default directory to the info page

@cappaert suggested Identikit on another forum as a very helpful tool, so over the past couple of days I have created my own key: Field/Photo ID for Flies - Key to Homalodisca

Identikit is awesome, and I managed to host my key on GitHub (like David).

I have a few questions:


First, how can I make it so that when one opens the tool, the page they are greeted with is the "About the Knowledge-base"?

I believe the relevant code for this may be:

var tombiovis = {

    opts: {

        hideVisDropdown: false,

        tools: ["vis1", "vis2", "vis3", "vis4", "vis5"],

        selectedTool: "vis1"

However, I have not found a way to manipulate this to my wants.


Next, when I change the ImageWidth in media.csv of a particular file to less than 100%, I get this annoying effect of empty gray space: ![](upload://1K2O3c4js7OFKAerNzPd9aC757r.png)

How can I change the width of the pop-up so that the image takes up the entire width, but the image itself doesn’t get any larger or smaller?

Alternatively, why isn’t the image centered, and how can I fix that?

Thanks so much!

Hello! Glad you are finding the Identikit useful.

To start with the about the knowledge base, set selectedTool to ‘kbInfo’. (This is covered in the ‘Deploying your visualisations’ document - not the ‘Building a knowledge-base’ document.)

I can’t see the image you posted but I think you are probably talking about the image that appears when you hover over a taxon (like a tooltip). Instead of setting the width to 50%, set it to the actual width you want in pixels, e.g. ‘150px’ - that will do what you want I think.

Rich

1 Like

Thank you for the response! I’ll play around with these settings and see what I like best.

I’m making my fourth key, these go really quickly compared to what I used to do (Google Slides)!!